Author Topic: Solved: Connecting Dell Axim x51v to windows 10  (Read 919 times)

Online alastairgott

  • 1 week till September...
  • forum hero
  • *****
  • Posts: 1577
  • silvestre en los bosques
    • SILVESTRE
Solved: Connecting Dell Axim x51v to windows 10
« on: May 02, 2018, 08:40:53 pm »

I've just got Pete's PDA to connect to my windows 10 PC.


Firstly I started by following the advice to download the windows mobile device centre for windows vista and save to my computer rather than run it straight away.


Then you have to right click on the program and enter the properties section, and run the compatibility troubleshooter. this should find that you need to install a vista compatibility pack. [do this]


Then I found the instructions on this website useful.
source: https://cmtinc.wordpress.com/2017/07/05/microsoft-stopped-supporting-windows-mobile-device-center-wmdc/
Quote
You could try to fix the issue with Mobile Device Center on Windows 10 as follows.
1) Add 2 registry entries as shown below by putting them in a text file then right-clicking on the file name (such as WMDC-Reg.bat) and selecting “Run as administrator”
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\RapiMgr /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
REG ADD HKLM\SYSTEM\CurrentControlSet\Services\WcesComm /v SvcHostSplitDisable /t REG_DWORD /d 1 /f
2) Restart the PC.
3) Click on the Windows Start icon and right-click on Windows Mobile Device Center. Select “Run as Administrator”. Now WMDC 6.1.6965 in Windows 10 version 1703 runs, but it shows “Disconnected”. Click on Mobile Device Settings then click on Connection Settings. Mark the check box for “Allow USB connections”. Unmark the check box for “Allow connections to one of the following:”.
4) Right-click on Windows Start icon and select “Computer Management”. Double-click on “Services and Applications” then double-click on “Service”. Scroll down and look for “Windows Mobile-2003-based device connectivity” and “Windows Mobile-based device connectivity”. Double-click on one of these services to view its properties. Click on the “Log On” tab then select “Local System account” as the log on mode. Do this for the other mobile-based device connectivity service as well.
Restart the PC.
5) On a PDA running Windows Mobile 5.0, tap the Windows Start icon then select “Settings”. Tap on the “Connections” tab. Unmark the check box for “Enable advanced network functionality”. Select “USB Settings” then select “Transmission as Serial Interface”. Now connect the PDA to the PC via USB. The Mobile Device Interface in PC-series will show that the PDA and the PC are communicating properly.
WMDC may still show “Disconnected”. It will show “Connected” after a restart.
On PDAs running Windows Mobile 6.0, after selecting “Connections”, tap on “USB to PC”. Mark the check box for “Enable advanced network functionality”. If successful, connect the PDA to the PC via USB and verify that PDA and PC are able to communicate with each other.[/l][/l]
You might have problems with the unmarking the box for “Enable advanced network functionality” I solved this as I had the disto on the com port for the Bluetooth, once I'd removed the com port for the disto, I could uncheck the box and connect the Axim via the windows mobile device centre.

Offline Swallowneck

  • addict
  • **
  • Posts: 120
Re: Solved: Connecting Dell Axim x51v to windows 10
« Reply #1 on: May 02, 2018, 09:37:45 pm »
You should have asked I could have saved you a lot faff with all that. You can of course do everything you need to do using the SD card and avoid all that Win10 WMDC nonsense.
Paperless surveying = hours and hours of fun, welcome to the club.

Online alastairgott

  • 1 week till September...
  • forum hero
  • *****
  • Posts: 1577
  • silvestre en los bosques
    • SILVESTRE
Re: Solved: Connecting Dell Axim x51v to windows 10
« Reply #2 on: May 02, 2018, 10:07:50 pm »
Sorry, refused to believe it was impossible, probably wasted a bit of time working out how.

I managed to get a Standard Micro SD card from work (not high def or any rubbish like that) of less than 2gb and put it in a SD Card adapter. That works now too!